设为首页   锐捷官网
用其他帐号登录:
查看: 2498|回复: 0

[讨论] 7.2 配置BGP >> 7.2.3 建立BGP对等体(组)

[复制链接]

72

主题

129

帖子

1670

积分

金牌会员

Rank: 6Rank: 6

积分
1670
发表于 2016-9-7 15:11:34 | 显示全部楼层 |阅读模式
本帖 * 后由 no_on 于 2016-9-8 14:21 编辑

7.2 配置BGP >> 7.2.3 建立BGP对等体(组)


BGP 作为一个外部网关协议(EGP), BGP Speaker 必须知道谁是其对等体(BGP Peer)。 BGP Speaker 之间建立连接关系的模式有两种: IBGP (Internal BGP)和 EBGP (External BGP)。通过 BGP Peer 所在的 AS 和本 BGP Speaker 所在的 AS 来判断 BGP Speakers 之间建立的是哪种连接模式。

>通常,建立 EBGP 连接的 BGP Speakers 之间在物理上直接相连,而建立 IBGP 连接的 BGP Speakers 可以在 AS 内的任何地方。
BGP 对等体

Ruijie(config-router)# neighbor address remote-as as-number     //配置一个 BGP 对等体。address 指明 BGP peer 的地址。as-number:的范围(1~4294967295)。
使用 no neighbor address remote-as 删除一个对等体。

例:配置了一个 IBGP peer 131.108.234.2,两个 EBGP peer: 131.108.200.1 和 150.136.64.19。
Ruijie(config)# router bgp 109
Ruijie(config-router)# neighbor 131.108.200.1 remote-as 167
Ruijie(config-router)# neighbor 131.108.234.2 remote-as 109
Ruijie(config-router)# neighbor 150.136.64.19 remote-as 99

BGP 对等体组
Ruijie(config-router)# neighbor peer-group-name peer-group                    //创建一个 BGP 对等体组。
Ruijie(config-router)# neighbor address peer-group peer-group-name      //加入一个组成员。
Ruijie(config-router)# neighbor peer-group-name remote-as as-number   //设置该组所在的 AS。as-number 的范围(1~4294967295)。如果所有组成员属于同一个 AS,则可以使用此命令统一设置全组所在的 AS。否则必须为每个成员使用 neighbor remote-as 命令设置其所在 AS。
对 BGP Speaker 来说,许多对等体的配置信息(包括执行的路由策略等)都相同,为了简化配置,提高效率, * 使用 BGP对等体组。
使用 no neighbor address peer-group 删除对等体组中某一成员。
使用 no neighbor peer-group-name peer-group 删除整个对等体组。
使用 no neighbor peer-group-name remote-as 删除对等体组的所有成员和对等体组的 AS 号。
例:配置 IBGP 对等体组,命名 internal-peers。
Ruijie(config)# router bgp 100
Ruijie(config-router)# neighbor internal-peers peer-group
Ruijie(config-router)# neighbor internal-peers remote-as 100
Ruijie(config-router)# neighbor internal-peers update-source loopback 0
Ruijie(config-router)# neighbor 171.69.232.53 peer-group internal-peers
Ruijie(config-router)# neighbor 171.69.232.54 peer-group internal-peers
Ruijie(config-router)# neighbor 171.69.232.55 peer-group internal-peers
例:配置 EBGP 对等体组,命名 external-peers
Ruijie(config)# router bgp 100
Ruijie(config-router)# neighbor external-peers peer-group
Ruijie(config-router)# neighbor 171.69.232.90 remote-as 200
Ruijie(config-router)# neighbor 171.69.232.90 peer-group external-peers
Ruijie(config-router)# neighbor 171.69.232.100 remote-as 300
Ruijie(config-router)# neighbor 171.69.232.100 peer-group external-peers
Ruijie(config-router)# neighbor 171.69.232.110 remote-as 400
Ruijie(config-router)# neighbor 171.69.232.110 peer-group external-peers

其他配置
Ruijie(config-router-af)# neighbor { address | peer-group-name }activate //在某地址族下激活已经配置的 BGP 邻居。>BGP 路由模式下配置的 BGP 邻居仅激活了IPv4 单播地址族,而其他地址族关闭。
Ruijie(config-router)# neighbor { address | peer-group-name }update-source interface //配置在同指定 BGP 对等体(组)之间建立 BGP session 时使用的网络接口。
>可以选定任何有效接口建立 TCP 连接。该命令的 * 作用是提供 Loopback 接口使用,使得到达 IBGP Speaker 的连接更加稳定。
Ruijie(config-router)# neighbor { address | peer-group-name }ebgp-multihop [ ttl ]//允许在非直连的 EBGP 对等体(组)之间建立 BGP session。 TTL 的范围(1~255), EBGP 缺省 1 跳,IBGP 缺省 255 跳。

>缺省情况下, EBGP 对等体之间必须在物理上直接相连。如果 EBGP 对等体之间并非直连,则必须配置此命令。需要多跳才能建立BGP 连接的 EBGP 对等体之间必须存在到达对方的非缺省的路由。
Ruijie(config-router)# neighbor { address | peer-group-name }password string//启动在同指定 BGP 对等体(组)建立连接时使用TCP MD5 认证,并配置密码。
>BGP 邻居上的认证密码必须相同。
Ruijie(config-router)# neighbor { address | peer-group-name }soft-reconfiguration inbound//重启 BGP session,并保留 BGP 对等体(组)发来的未经更改的路由信息。
Ruijie(config-router)# neighbor { address | peer-group-name }shutdown //关闭同对等体(组)建立的有效连接,但保留为该指定对等体(组)设置的配置信息。
>使用以上命令的 no 模式,可以使配置的内容失效。
>缺省情况下,对等体组的每个成员继承对等体组的所有配置。同时,每个成员允许单独配置不影响输出更新的可选配置,取代对等体组的统一配置。如下配置是每个组成员必须继承对等体组的: remote-as、 update-source、 local-as、reconnect-interval、 times、 advertisemet-interval、 default-originate、 next-hop-self、 password remove-private-as、send-community、 distribute-list out、 filter-list out、 prefix-list out、 route-map out、 unspress-map、 route-reflector-client。
例:配置对 BGP 连接进行 MD5 认证,密码为 peerpassword
Ruijie(config)# router bgp 100
Ruijie(config-router)# neighbor 171.69.232.54 remote-as 110
Ruijie(config-router)# neighbor 171.69.232.54 password peerpassword


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则