设为首页   锐捷官网
用其他帐号登录:
查看: 1941|回复: 0

[讨论] 6 Super VLAN >> 6.3 Super VLAN典型配置用例

[复制链接]

72

主题

129

帖子

1670

积分

金牌会员

Rank: 6Rank: 6

积分
1670
发表于 2016-6-15 16:53:08 | 显示全部楼层 |阅读模式
本帖 * 后由 no_on 于 2016-6-15 16:57 编辑

6 Super VLAN >> 6.3 Super VLAN典型配置用例

组网拓扑

6-2 Super VLAN 应用拓扑

Super VLAN典型配置用例

Super VLAN典型配置用例


应用需求

如上图所示, Switch A 作为汇聚设备,通过 Trunk 口下联接入设备 Switch B、 Switch C、 Switch D。
应用需求如下:
>>接入用户通过划分 VLAN 实现二层隔离。
>>所有 VLAN 用户共享一个 IP 网关,实现三层通信以及与外网通信。


配置要点


>>在接入设备(本例为 Switch B、 Switch C、 Switch D)上仅需按照普通 VLAN (本例为 VLAN 10、 VLAN 20、 VLAN30)实现二层通信隔离。
>>在汇聚设备(本例为 Switch A)上配置 Super VLAN(本例为 VLAN 2)功能,将接入设备上的 VLAN(本例为 VLAN10、 VLAN 20、 VLAN 30)设置为 Sub-VLAN。
>>为 Super VLAN 设置 SVI(本例为 192.168.1.1/24),并且为各个 Sub-VLAN 分配 IP 地址范围(本例如上图所示)。

配置步骤

以下仅针对 Switch A 进行配置举例,对于接入设备 Switch B、 Switch C、 Switch D 的 VLAN 划分情况不再列举。
>>配置 Switch A
* 步,进入全局配置模式,创建 VLAN 2、 VLAN 10、 VLAN 20、 VLAN 30。

Ruijie#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#vlan 2
Ruijie(config-vlan)#exit
Ruijie(config)#vlan 10
Ruijie(config-vlan)#exit
Ruijie(config)#vlan 20
Ruijie(config-vlan)#exit
Ruijie(config)#vlan 30
Ruijie(config-vlan)#exit

* 步,设置 VLAN 2 为 Super VLAN,对应的 Sub-VLAN 为 VLAN 10、 VLAN 20、 VLAN 30。

Ruijie(config)#vlan 2
Ruijie(config-vlan)#supervlan
Ruijie(config-vlan)#subvlan 10,20,30
Ruijie(config-vlan)#exit

第三步,设置 Super VLAN 2 对应的三层虚拟接口,与 Super VLAN 2 关联的所有 Sub-VLAN 用户将通过该接口进行三层通信。

Ruijie(config)#interface vlan 2
Ruijie(config-if-VLAN 2)#ip address 192.168.196.1 255.255.255.0

第四步,设置 Sub-VLAN 10 的 IP 地址范围为 192.168.196.10~192.168.196.50, Sub-VLAN 20 的 IP 地址范围为192.168.196.60~192.168.196.100, Sub-VLAN 30 的 IP 地址范围为 192.168.196.110~192.168.196.150。

Ruijie(config)#vlan 10
Ruijie(config-vlan)#subvlan-address-range 192.168.196.10 192.168.196.50
Ruijie(config-vlan)#exit
Ruijie(config)#vlan 20
Ruijie(config-vlan)#subvlan-address-range 192.168.196.60 192.168.196.100
Ruijie(config-vlan)#exit
Ruijie(config)#vlan 30
Ruijie(config-vlan)#subvlan-address-range 192.168.196.110 192.168.196.150

第五步,设置端口 Gi 0/1、 Gi 0/5、 Gi 0/9 为 Trunk 口,用于连接 Switch B、 Switch C、 Switch D。

Ruijie(config)#interface range gigabitEthernet 0/1,0/5,0/9
Ruijie(config-if-range)#switchport mode trunk



验证结果

* 步,查看 Switch A 的配置信息,关注点: Super VLAN 和 Sub-VLAN 的映射关系、 Sub-VLAN 的 IP 地址范围、 SuperVLAN 的网关地址是否配置正确。
Ruijie#show running-config
!
vlan 1
!
vlan 2
supervlan
subvlan 10,20,30
!
vlan 10
subvlan-address-range 192.168.196.10 192.168.196.50
!
vlan 20
subvlan-address-range 192.168.196.60 192.168.196.100
!
vlan 30
subvlan-address-range 192.168.196.110 192.168.196.150
!
interface GigabitEthernet 0/1
switchport mode trunk
!
interface GigabitEthernet 0/5
switchport mode trunk
!
interface GigabitEthernet 0/9
switchport mode trunk
!
interface VLAN 2
no ip proxy-arp
ip address 192.168.196.1 255.255.255.0
* 步,查看 Super VLAN 的配置情况,如显示信息所示: Super VLAN 和 Sub-VLAN 的 ARP 代理功能默认是开启的。
Ruijie(config-if-range)# show supervlan
supervlan id supervlan arp-proxy subvlan id subvlan arp-proxy subvlan ip range
------------ ------------------- -------------------------
2 ON  10 ON 192.168.196.10 - 192.168.196.50
          20 ON 192.168.196.60 - 192.168.196.100
          30 ON 192.168.196.110 - 192.168.196.150




回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则