设为首页   锐捷官网
用其他帐号登录:
查看: 2131|回复: 0

[讨论] 4 OSPF >> 4.4 配置举例 >> 4.4.16 OSPF无环路备份路径

[复制链接]

72

主题

129

帖子

1670

积分

金牌会员

Rank: 6Rank: 6

积分
1670
发表于 2016-3-25 14:46:21 | 显示全部楼层 |阅读模式
本帖 * 后由 no_on 于 2016-6-30 10:21 编辑

4 OSPF  >>  4.4 配置举例 >> 4.4.16 OSPF无环路备份路径
配置要求
四台路由设备 S2GW1GW2D,属于同一 OSPF 区域,两两通过 OSPF 协议实现网络互连。 D 通告路由 192.168.5.1/32S2 GW2 OSPF 接口代价配置为 1000,其它接口代价为缺省值。要求配置链路节点保护的无环路备份路径,使得 S2计算到达 D 的主路由经过 S2GW1D,备份路由经过 S2GW2D,当 S2 GW1 之间的链路出现故障时,到达 D 业务可以快速切换到 S2 GW2 之间的链路上。


OSPF无环路备份路径

OSPF无环路备份路径

配置过程
设备 S2 的配置
#配置以太网端口
interface GigabitEthernet 0/1
ip address 192.168.1.2 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
ip ospf fast-reroute protection link-node
carrier-delay 0
interface GigabitEthernet 0/2
ip address 192.168.3.2 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
ip ospf cost 1000
carrier-delay 0

#配置 OSPF 路由协议及快速重路由
router ospf 1
network 192.168.0.0 0.0.255.255 area 0
fast-reroute lfa

设备 GW1 配置
#配置以太网端口
interface GigabitEthernet 0/1
ip address 192.168.1.1 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
interface GigabitEthernet 0/2
ip address 192.168.2.1 255.255.255.0

bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
#配置 OSPF 路由协议
router ospf 1
network 192.168.0.0 0.0.255.255 area 0

设备 GW2 的配置
#配置以太网端口
interface GigabitEthernet 0/1
ip address 192.168.3.1 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
interface GigabitEthernet 0/2
ip address 192.168.4.1 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
#配置 OSPF 路由协议

router ospf 1
network 192.168.0.0 0.0.255.255 area 0
设备 D 的配置
#配置以太网端口
interface GigabitEthernet 0/1
ip address 192.168.2.2 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
interface GigabitEthernet 0/2
ip address 192.168.4.2 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
#配置换回端口
interface Loopback 1
ip address 192.168.5.1 255.255.255.255
#配置 OSPF 路由协议

router ospf 1
network 192.168.0.0 0.0.255.255 area 0

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则