设为首页   锐捷官网
用其他帐号登录:
查看: 2065|回复: 0

[讨论] 4 OSPF >> 4.4 配置举例 >> 4.4.15 OSPF快速重路由

[复制链接]

72

主题

129

帖子

1670

积分

金牌会员

Rank: 6Rank: 6

积分
1670
发表于 2016-3-25 14:33:17 | 显示全部楼层 |阅读模式
本帖 * 后由 no_on 于 2016-6-30 10:20 编辑

4 OSPF  >>  4.4 配置举例 >> 4.4.15 OSPF快速重路由
配置要求
三台路由设备 ABC 属于同一 OSPF 区域,两两通过 OSPF 协议实现网络互连。要求当 B C 之间的链路出现故障时,业务可以快速切换到 C A 之间的链路上,通过 CAB 到达 B。

OSPF快速重路由

OSPF快速重路由

配置过程
设备 A 的配置
#配置以太网端口
interface GigabitEthernet 0/1
ip address 192.168.1.1 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
interface GigabitEthernet 0/2
ip address 192.168.2.1 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
#配置 OSPF 路由协议

router ospf 1
network 192.168.0.0 0.0.255.255 area 0



设备 B 的配置
#配置以太网端口
interface GigabitEthernet 0/1
ip address 192.168.2.2 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
interface GigabitEthernet 0/2
ip address 192.168.3.1 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd

#配置 OSPF 路由协议
router ospf 1
network 192.168.0.0 0.0.255.255 area 0


设备 C 的配置
#配置以太网端口
interface GigabitEthernet 0/1
ip address 192.168.1.2 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
carrier-delay 0
interface GigabitEthernet 0/2
ip address 192.168.3.2 255.255.255.0
bfd interval 200 min_rx 200 multiplier 5
ip ospf bfd
carrier-delay 0


#配置路由图
route-map frr
match interface gigabitEthernet 0/2
set fast-reroute backup-interface GigabitEthernet 0/1 backup-nexthop 192.168.1.1
#配置 OSPF 路由协议及快速重路由
router ospf 1
network 192.168.0.0 0.0.255.255 area 0
fast-reroute route-map frr





回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则