设为首页   锐捷官网
用其他帐号登录:
查看: 1745|回复: 0

[讨论] 4 OSPF >> 4.4 配置举例 >> 4.4.6 OSPF重分布动态路由

[复制链接]

72

主题

129

帖子

1670

积分

金牌会员

Rank: 6Rank: 6

积分
1670
发表于 2016-3-23 15:00:42 | 显示全部楼层 |阅读模式
本帖 * 后由 no_on 于 2016-6-29 12:13 编辑

4 OSPF  >>  4.4 配置举例 >> 4.4.6 OSPF重分布动态路由
配置要求
有四台设备,设备连接图如下图所示。路由设备 A 属于 OSPF 路由域,路由设备 C 属于 RIP 路由域,路由设备 D 属于 BGP路由域,路由设备 B 连接三个路由域。路由设备 A 通告 192.168.10.0/24192.168.100.1/32 两条路由,路由设备 C 通告192.168.3.0/24192.168.30.0/24 两条路由,路由设备 D 通告 192.168.4.0/24192.168.40.0/24 两条路由。在设备 Router B 上, OSPF 重分布 RIP 路由域中的路由,路由类型为 Type-1,重分布 BGP 路由域中携带团体属性 11:11的路由; RIP 重分布 OSPF 路由域中的192.168.10.0/24 路由,度量值设为 2,并且通告一条默认路由到 RIP 域。

OSPF重分布动态路由

OSPF重分布动态路由
具体配置
&说明:路由协议之间进行重分布路由,简单的路由过滤可以由分布列表来控制。如果要对不同的路由设置不同的属性,分布列表是做不到的,需要配置路由图进行控制。路由图比分布列表提供了更多的控制功能,但是配置也相对复杂。在本例中配置路由图对 BGP 路由的团体属性进行匹配。



######
路由设备 A 的配置
# 配置网络接口
Ruijie(config)# interface gigabitEthernet 0/1
Ruijie(config-if-GigabitEthernet 0/1)# ip address 192.168.10.1 255.255.255.0
Ruijie(config)# interface loopback 1
Ruijie(config-if-Loopback 1)# ip address 192.168.100.1 255.255.255.255
Ruijie(config-if-Loopback 1)# no ip directed-broadcast
Ruijie(config)# interface gigabitEthernet 0/2
Ruijie(config-if-GigabitEthernet 0/2)# ip address 192.168.12.1 255.255.255.0
# 配置 OSPF
Ruijie(config)# router ospf 12
Ruijie(config-router)# network 192.168.10.0 0.0.0.255 area 0
Ruijie(config-router)# network 192.168.12.0 0.0.0.255 area 0
Ruijie(config-router)# network 192.168.100.0 0.0.0.255 area 0

########
路由设备 B 的配置
# 配置网络接口
Ruijie(config)# interface gigabitEthernet 0/1
Ruijie(config-if-GigabitEthernet 0/1)# ip address 192.168.12.2 255.255.255.0
Ruijie(config)# interface gigabitEthernet 0/2
Ruijie(config-if-GigabitEthernet 0/2)# ip address 192.168.24.2 255.255.255.0
Ruijie(config)# interface Serial 1/0
Ruijie(config-Serial 1/0)# ip address 192.168.23.2 255.255.255.0
# 配置 OSPF,设置重分布路由的类型
Ruijie(config)# router ospf 12
Ruijie(config-router)# redistribute rip metric 100 metric-type 1 subnets
Ruijie(config-router)# redistribute bgp route-map ospfrm subnets
Ruijie(config-router)# network 192.168.12.0 0.0.0.255 area 0

# 配置 RIP,分布列表过滤重分布路由
Ruijie(config)# router rip
Ruijie(config-router)# redistribute ospf 12 metric 2
Ruijie(config-router)# network 192.168.23.0
Ruijie(config-router)# distribute-list 10 out ospf
Ruijie(config-router)# default-information originate always
Ruijie(config-router)# no auto-summary

# 配置 BGP
Ruijie(config)# router bgp 2
Ruijie(config-router)# neighbor 192.168.24.4 remote-as 4
Ruijie(config-router)# address-family ipv4
Ruijie(config-router-af)# neighbor 192.168.24.4 activate
Ruijie(config-router-af)# neighbor 192.168.24.4 send-community

# 配置路由图
Ruijie(config)# route-map ospfrm
Ruijie(config-route-map)# match community cl_110
# 定义访问列表
Ruijie(config)# access-list 10 permit 192.168.10.0
# 定义 community 列表
Ruijie(config)# ip community-list standard cl_110 permit 11:11
########
路有器 C 的配置
Ruijie(config)# interface gigabitEthernet 0/1
Ruijie(config-if-GigabitEthernet 0/1)# ip address 192.168.30.1 255.255.255.0
Ruijie(config)# interface gigabitEthernet 0/2
Ruijie(config-if-GigabitEthernet 0/2)# ip address 192.168.3.1 255.255.255.0
Ruijie(config)# interface Serial 1/0
Ruijie(config-Serial 1/0)# ip address 192.168.23.3 255.255.255.0

# 配置 RIP
Ruijie(config)# router rip
Ruijie(config-router)# network 192.168.23.0
Ruijie(config-router)# network 192.168.3.0
Ruijie(config-router)# network 192.168.30.0

########
路有器 D 的配置
# 配置网络接口
Ruijie(config)# interface gigabitEthernet 0/1
Ruijie(config-if-GigabitEthernet 0/1)# ip address 192.168.40.1 255.255.255.0
Ruijie(config)# interface gigabitEthernet 0/2
Ruijie(config-if-GigabitEthernet 0/1)# ip address 192.168.4.1 255.255.255.0
Ruijie(config)# interface gigabitEthernet 0/3
Ruijie(config-if-GigabitEthernet 0/3)# ip address 192.168.24.4 255.255.255.0

# 配置 BGP
Ruijie(config)# router bgp 4
Ruijie(config-router)# neighbor 192.168.24.2 remote-as 2
Ruijie(config-router)# redistribute connected route-map bgprm
Ruijie(config-router)# address-family ipv4
Ruijie(config-router-af)# neighbor 192.168.24.2 activate
Ruijie(config-router-af)# neighbor 192.168.24.2 send-community

# 配置路由图
Ruijie(config)# route-map bgprm
Ruijie(config-route-map)# set community 22:22
####
路由设备 A 看到的 OSPF 路由
O E1 192.168.30.0/24[110/101]via 192.168.12.2,00:04:07, gigabitEthernet 0/2
O E1 192.168.3.0/24[110/101]via 192.168.12.2,00:04:07, gigabitEthernet 0/2
O E1 192.168.23.0/24[110/101]via 192.168.12.2,00:04:07, gigabitEthernet 0/2

####
路由设备 C 看到的 RIP 路由
R 0.0.0.0/0 [120/1] via 192.168.23.2, 00:00:00, Serial 1/0
R 192.168.10.0/24 [120/2] via 192.168.23.2, 00:00:00, Serial 1/0
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则