设为首页   锐捷官网
用其他帐号登录:
查看: 1839|回复: 0

[讨论] 4 OSPF >> 4.4 配置举例 >> 4.4.4 OSPF ABR、 ASBR

[复制链接]

72

主题

129

帖子

1670

积分

金牌会员

Rank: 6Rank: 6

积分
1670
发表于 2016-3-23 14:31:05 | 显示全部楼层 |阅读模式
本帖 * 后由 no_on 于 2016-6-29 11:59 编辑

4 OSPF  >>  4.4 配置举例 >> 4.4.4 OSPF ABR、 ASBR
配置要求
有四台设备组成了一个 OSPF 路由域,网络 192.168.12.0/24192.168.23.0/24 属于区域 0,网络 192.168.34.0/24 属于区34。具体 IP 地址分配和设备连接图见下图。

OSPF ABR、 ASBR

OSPF ABR、 ASBR
如图所示,设备 AB 为区域内部设备,设备 C 为区域边界设备,设备 D 为自治域边界设备。200.200.1.0/24172.200.1.0/24OSPF 路由域外的网络。通过配置各设备,使得所有 OSPF 设备学到外部路由,要求外部路由携带“34”标记以及类型为外部路由 I 型。
设备具体配置
&说明:OSPF 重分布其它来源的路由时,缺省类型为 II 型,而且不携带任何标记。
设备 A 的配置:
#配置以太网端口
interface FastEthernet 0/1
ip address 192.168.12.1 255.255.255.0
#配置 OSPF 路由协议
router ospf 1
network 192.168.12.0 0.0.0.255 area 0

设备 B 的配置:
#配置以太网端口
interface FastEthernet 0/1
ip address 192.168.12.2 255.255.255.0
#配置广域网端口
interface Serial 1/0
ip address 192.168.23.2 255.255.255.0
#配置 OSPF 路由协议
router ospf 1
network 192.168.12.0 0.0.0.255 area 0
network 192.168.23.0 0.0.0.255 area 0

设备 C 的配置:
#配置以太网端口
interface FastEthernet 0/1
ip address 192.168.34.3 255.255.255.0
#配置广域网端口
interface Serial 1/0
ip address 192.168.23.3 255.255.255.0
#配置 OSPF 路由协议

router ospf 1
network 192.168.23.0 0.0.0.255 area 0
network 192.168.34.0 0.0.0.255 area 34
设备 D 的配置:
#配置以太网端口
interface FastEthernet 0/1
ip address 192.168.34.4 255.255.255.0
#配置以太网卡上的端口
interface FastEthernet 0/1
ip address 200.200.1.1 255.255.255.0
interface FastEthernet 0/2
ip address 172.200.1.1 255.255.255.0
#配置 OSPF 路由协议,重分布 RIP 路由
router ospf 1
network 192.168.34.0 0.0.0.255 area 34
redistribute rip metric-type 1 subnets tag 34

#配置 RIP 路由协议
router rip
network 200.200.1.0
network 172.200.0.0

在设备 B 上看到 ospf 生成的路由如下,注意外部路由类型变为“ E1”了。
O E1 200.200.1.0/24 [110/85] via 192.168.23.3,00:00:33,Serial 1/0
O IA 192.168.34.0/24 [110/65] via 192.168.23.3,00:00:33,Serial 1/0
O E1 172.200.1.0 [110/85] via 192.168.23.3,00:00:33,Serial 1/0

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则