设为首页   锐捷官网
用其他帐号登录:
查看: 1680|回复: 0

[讨论] 4 OSPF >> 4.4 配置举例 >> 4.4.3 OSPF点到多点广播网络类型

[复制链接]

72

主题

129

帖子

1670

积分

金牌会员

Rank: 6Rank: 6

积分
1670
发表于 2016-3-23 14:23:08 | 显示全部楼层 |阅读模式
本帖 * 后由 no_on 于 2016-6-29 11:50 编辑

4 OSPF  >>  4.4 配置举例 >> 4.4.3 OSPF点到多点广播网络类型
配置要求
三台设备要通过帧中继网络实现互联,每台设备只有一条帧中继线路,线路带宽和 PVC 速率全部一样。 IP 地址分配和设备连接图见下图。要求:设备 A BC 之间配置点到多点类型网络。

OSPF点到多点广播网络类型

OSPF点到多点广播网络类型
设备具体配置
&说明:
如果接口配置了点到多点网络类型,点到多点网络类型没有竞选指定设备的过程, OSPF 操作与点到点网络类型的行为很类似。


1、设备 A 的配置:
#配置以太网端口
interface FastEthernet 0/1
ip address 192.168.12.1 255.255.255.0
#配置广域网端口
interface Serial 1/0
ip address 192.168.123.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint

#配置 OSPF 路由协议
router ospf 1
network 192.168.12.0 0.0.0.255 area 0
network 192.168.123.0 0.0.0.255 area 0


2、设备 B 的配置:
#配置以太网端口
interface FastEthernet 0/1
ip address 192.168.23.2 255.255.255.0
#配置广域网端口
interface Serial 1/0
ip address 192.168.123.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
#配置 OSPF 路由协议
router ospf 1
network 192.168.23.0 0.0.0.255 area 0
network 192.168.123.0 0.0.0.255 area 0


3、设备 C 的配置:
#配置以太网端口
interface FastEthernet 0/1
ip address 192.168.23.3 255.255.255.0
#配置广域网端口
interface Serial 1/0
ip address 192.168.123.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
#配置 OSPF 路由协议
router ospf 1
network 192.168.23.0 0.0.0.255 area 0
network 192.168.123.0 0.0.0.255 area 0

假设还有一个需求是:设备 A 192.168.23.0/24 目标网络将优先选择设备 B;要达到优先选路的要求,必须在配置邻居时设置该邻居的花费。可以在设备 A 中配置如下命令:
router ospf 1
neighbor 192.168.123.2 cost 100
neighbor 192.168.123.3 cost 200
&说明:P2MP 类型不要求全网状连接。P2MP 类型可以看作是多个P2P 链路,产生多个主机路由。P2MP类型选举DR和BDR,允许设置到每个邻居的度量值。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则