设为首页   锐捷官网
用其他帐号登录:
查看: 1512|回复: 0

[讨论] 4 OSPF >> 4.4 配置举例 >> 4.4.2 OSPF NBMA网络类型

[复制链接]

72

主题

129

帖子

1670

积分

金牌会员

Rank: 6Rank: 6

积分
1670
发表于 2016-3-23 14:14:17 | 显示全部楼层 |阅读模式
本帖 * 后由 no_on 于 2016-6-29 11:49 编辑

4 OSPF  >>  4.4 配置举例 >> 4.4.2 OSPF NBMA网络类型
配置要求
三台设备要通过帧中继网络实现网状全连接,每台设备只有一条帧中继线路,线路带宽和PVC速率全部一样。 IP地址分配和设备连接图见下图。

OSPF NBMA网络类型

OSPF NBMA网络类型
要求:
      设备 ABC 之间配置 NBMA 类型网络;
      设备 A 为指定设备,设备 B 为备份指定设备;
      全部网络都在一个区域内;
      加快拓扑收敛。
设备具体配置
&说明:由于OSPF没有特殊配置,将采用组播方式自动发现邻居, 如果接口配置了NBMA网络类型,该接口就不会发OSPF组播报文,因此需要指定邻居的IP地址。可以通过设置较短的SPF计算等待时间来加快拓扑收敛。



  • 设备 A 的配置:
    #配置广域网端口
    interface Serial 1/0
    ip address 192.168.123.1 255.255.255.0
    encapsulation frame-relay
    ip ospf network non-broadcast
    ip ospf priority 10

    #配置OSPF路由协议,到设备B的花费更小
    router ospf 1
    network 192.168.123.0 0.0.0.255 area 0
    neighbor 192.168.123.2 priority 5
    neighbor 192.168.123.3
    timers throttle spf 500 1000 10000

    2、设备 B 的配置:
    #配置广域网端口
    interface Serial 1/0
    ip address 192.168.123.2 255.255.255.0
    encapsulation frame-relay
    ip ospf network non-broadcast
    ip ospf priority 5

    #配置 OSPF 路由协议
    router ospf 1
    network 192.168.123.0 0.0.0.255 area 0
    neighbor 192.168.123.1 priority 10
    neighbor 192.168.123.3
    timers throttle spf 500 1000 10000

    3、设备 C 的配置:
    #配置广域网端口
    interface Serial 1/0
    ip address 192.168.123.3 255.255.255.0
    encapsulation frame-relay
    ip ospf network non-broadcast
    #配置 OSPF 路由协议
    router ospf 1
    network 192.168.123.0 0.0.0.255 area 0

    neighbor 192.168.123.1 priority 10
    neighbor 192.168.123.2 priority 5
    timers throttle spf 500 1000 10000

    &说明:
    NBMA 类型要求全网状连接,所有互联的设备必须能够直接通讯。
    NBMA 类型以单播方式发送OSPF报文,必须手动指定邻居,需要选举DR和BDR。


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则