设为首页   锐捷官网
用其他帐号登录:
查看: 1368|回复: 0

AP110/120-W基础配置————多个无线信号配置

[复制链接]

25

主题

25

帖子

152

积分

版主

Rank: 7Rank: 7Rank: 7

积分
152
发表于 2016-1-9 19:33:30 | 显示全部楼层 |阅读模式
本帖 * 后由 浪天涯星仔 于 2016-1-9 19:44 编辑

适用场景说明
无线网络中的AP数量较少,不需要花费太大时间和精力去管理和配置AP。此时胖AP工作模式类似一台二层交换机,担任有线和无线数据转换的角色,没有路由和NAT功能。
优点:无需改变现有有线网络结构,配置简单
缺点:无法统一管理和配置
一、组网需求
通过基础配置,无线用户能够收到无线信号并且获取到IP地址;
AP110/120-W前面板的F0/2接口vlan和无线vlan不一样。

二、组网拓扑
1.png
注:
            1、接入交换机必须是可配置,支持trunk的交换机
            2、无线用户1是使用vlan1,那么在trunk链路中是不带vlan tag
            
三、配置要点
1、Telnet到AP
2、登陆设备特权模式
3、将AP模式切换为胖AP
4、配置enable密码
5、保存配置( * )
6、更改PC连接端口并重新Telnet
7、新建vlan
8、FA0/1以太网物理接口封装vlan
9、定义SSID
10、创建射频卡子接口
11、SSID和射频卡进行关联
12、开启广播功能( * )
13、配置AP的管理IP地址及默认路由
14、配置汇聚交换机及接入交换机

以下主要是配置介绍,配置可以直接复制案例介绍 * 后的脚本文件,根据实际的网络环境修改脚本文件中的部分内容,详见案例 * 后的脚本。


四、配置步骤
AP配置

接口编号:
2.png
注:
AP110-W瘦模式telnet密码是ruijie
  10.4(1b19)p2 173487版本
后面板地址:192.168.110.1/24
前面板地址:192.168.111.1/24
  10.4(1b19)p2 173487之前的P2版本
后面板地址:192.168.1.1/24
前面板地址:192.168.2.1/24
1、Telnet到AP(假设AP110-W的是10.4(1b19)p2 173487之前的P2版本)
1)打开电源,PC需要连接到AP的FA0/1(背面板的以太端口)
连接方式:PC---POE供电---(FA0/1)AP

2)PC IP地址设置为192.168.1.2
3.png
3)Telnet 到AP
telnet 192.168.1.1
User Access Verification
Password:ruijie
2、登陆设备特权模式
Ruijie>enable
Password:apdebug
Ruijie#
3、将AP模式切换为胖AP
Ruijie#ap-mode fat
apmode will change to FAT.
注:切换为胖AP之后,FA0/1、FA0/2转化为三层接口,FA0/1 IP地址:192.168.1.1/24,FA0/2 IP地址:192.168.2.1/24
4、配置enable密码,并设置管理地址
           Ruijie(config)#enable password ruijie
     Ruijie(config)#vlan 1 ------>无线用户1的vlan
           Ruijie(config-vlan)#vlan 2   ------>无线用户2的vlan
           Ruijie(config-vlan)#vlan 3   ------>有线用户的vlan
    Ruijie(config-vlan)#exit
           Ruijie(config)#interface BVI 3    ------>AP的管理地址,bvi 3 与vlan 3对应
           Ruijie(config-if-bvi)#ip address 192.168.3.100 255.255.255.0
           Ruijie(config-if-bvi)#interface Fastethernet 0/2
           Ruijie(config-if- Fastethernet )#encapsulation dot1Q 3      ------>前面板的F0/2封装vlan。在主接口封装vlan 表示access接口或trunk的native vlan
    Ruijie(config-if- Fastethernet )#line vty 0 4 ------>配置telnet
    Ruijie(config-line)#password 123456 ------>设置telnet密码为123456
    Ruijie(config-line)#login ------>启用vty线路认证
注:在第3步完成后不能退出特权模式,不然需要重新再进行一次胖瘦切换,用户模式也可以进行胖瘦切换。
5、更改PC连接端口并重新Telnet
1)PC连接到AP的FA0/2(正面板的以太端口)
连接方式:PC---(FA0/2)AP
2)PC IP地址设置为192.168.3.1
3)Telnet 到AP
telnet 192.168.3.100
User Access Verification
Password:ruijie
Ruijie>enable
Password:123456
6、测试登陆成功后,保存配置( * )
Ruijie#write
如果从F0/2接口无法登陆,请把AP切换为瘦模式(Ruijie>ap-mode fit),然后再重复步骤1--5
7、FA0/1以太网物理接口封装vlan
Ruijie(config)#interface fastEthernet 0/1
Ruijie(config-if-FastEthernet 0/1)#encapsulation dot1Q 1   ------>前面板的F0/2封装vlan。在主接口封装vlan 表示access接口或trunk的native vlan
Ruijie(config-if-FastEthernet 0/1)#interface fastEthernet 0/1.2   ------>子接口封装vlan,表示trunk接口,该接口发出的报文是有带vlan tag
Ruijie(config-if-FastEthernet 0/1.2)#encapsulation dot1Q 2       ------>封装无线用户2的vlan,使vlan 2能通过该接口上传到接入交换机
Ruijie(config-if-FastEthernet 0/1.2)#interface fastEthernet 0/1.3  ------>子接口封装vlan,表示trunk接口,该接口发出的报文是有带vlan tag
Ruijie(config-if-FastEthernet 0/1.3)#encapsulation dot1Q 3      ------>封装有线用户的vlan,使vlan 3能通过该接口上传到接入交换机
8、定义SSID
Ruijie(config)#dot11 wlan 1
Ruijie(dot11-wlan-config)#ssid ruijie1   ------>发出无线信号为“ruijie1”
Ruijie(dot11-wlan-config)#vlan 1     ------>无线用户1 的vlan
Ruijie(config)#dot11 wlan 2
Ruijie(dot11-wlan-config)#ssid ruijie2
Ruijie(dot11-wlan-config)#vlan 2
9、创建射频卡子接口
Ruijie(config)#interface dot11radio 1/0.1     ------>创建射频子接口
Ruijie(config-subif)#encapsulation dot1Q 1  ------>封装无线用户1的vlan 并且此vlan要和以太物理接口一致
Ruijie(config-subif)#mac-mode fat
Ruijie(config-subif)#interface dot11radio 1/0.2
Ruijie(config-subif)#encapsulation dot1Q 2  ------>封装无线用户2的vlan 并且此vlan要和以太物理接口一致
Ruijie(config-subif)#mac-mode fat
10、SSID和射频卡进行关联
Ruijie(config)#interface dot11radio 1/0
Ruijie(config-if-Dot11radio 1/0)#wlan-id 1
Ruijie(config-if-Dot11radio 1/0)#wlan-id 2
注:第8步、第9步、第10步顺序不能颠倒,完成这一部之后可以看到AP已经发出无线信号。
11、开启广播功能( * )
Ruijie(config)#data-plane wireless-broadcast enable
12、配置AP的默认路由
Ruijie(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.1
13、 * 接AP的线路插在电脑上可以正常通信。
14、配置DHCP服务(可选,如果内网没有配置用户自动获取地址功能时可以在AP上配置DHCP)
Ruijie(config)#service dhcp   ------>开启DHCP服务
Ruijie(config)#ip dhcp excluded-address 192.168.1.1------>不下发的地址
Ruijie(config)#ip dhcp excluded-address 192.168.2.1
Ruijie(config)#ip dhcp excluded-address 192.168.3.1
Ruijie(config)#ip dhcp excluded-address 192.168.3.100
Ruijie(config)#ip dhcp pool ruijie1 ------>配置DHCP地址池,名称是 “ruijie1”
Ruijie(dhcp-config)#network 192.168.1.0 255.255.255.0 ------>下发192.168.1.0地址段
Ruijie(dhcp-config)#dns-server 218.85.157.99  ------>下发DNS地址
Ruijie(dhcp-config)#default-router 192.168.1.1------>下发网关
Ruijie(dhcp-config)#exit
Ruijie(config)#ip dhcp pool ruijie2 ------>配置DHCP地址池,名称是 “ruijie1”
Ruijie(dhcp-config)#network 192.168.2.0 255.255.255.0 ------>下发192.168.2.0地址段
Ruijie(dhcp-config)#dns-server 218.85.157.99  ------>下发DNS地址
Ruijie(dhcp-config)#default-router 192.168.2.1------>下发网关
Ruijie(dhcp-config)#exit
Ruijie(config)#ip dhcp pool ruijie3 ------>配置有线用户的DHCP地址池,名称是 “ruijie3”
Ruijie(dhcp-config)#network 192.168.3.0 255.255.255.0 ------>下发192.168.3.0地址段
Ruijie(dhcp-config)#dns-server 218.85.157.99  ------>下发DNS地址
Ruijie(dhcp-config)#default-router 192.168.3.1------>下发网关
Ruijie(config)#interface bvi 1  ------>创建BVI地址,用于DHCP分配地址
Ruijie(config-if-BVI 1)#ip address 192.168.1.253 255.255.255.0
Ruijie(config-if-BVI 1)#interface bvi 2 ------>创建BVI地址,用于DHCP分配地址
Ruijie(config-if-BVI 2)#ip address  192.168.2.253 255.255.255.0
Ruijie(config-if-BVI 2)#interface bvi 3 ------>创建BVI地址,用于DHCP分配地址
Ruijie(config-if-BVI 3)#ip address  192.168.2.253 255.255.255.0
15、保存配置
           Ruijie(dhcp-config)#end
           Ruijie#write

接入交换机配置:与AP、核心交换机相连的接口必须配置成trunk
1、配置互联接口
Ruijie>enable
Ruijie#configure terminal
Ruijie(config)#interface fastEthernet 0/1
Ruijie(config-if-FastEthernet 0/1)#switchport mode trunk
Ruijie(config-if-FastEthernet 0/1)#interface fastEthernet 0/2
Ruijie(config-if-FastEthernet 0/2)#switchport mode trunk
2、创建vlan   ------>必须配置,否则AP数据无法通过
Ruijie(config)#vlan 1
Ruijie(config-vlan)#vlan 2
Ruijie(config-vlan)#vlan 3
Ruijie(config-vlan)#exit
3、保存配置
           Ruijie(config)#end
           Ruijie#write
核心交换机配置:
1、配置互联接口
Ruijie>enable
Ruijie#configure terminal
Ruijie(config)#interface fastEthernet 0/2
Ruijie(config-if-FastEthernet 0/2)#switchport mode trunk
Ruijie(config-if-FastEthernet 0/2)#exit
2、创建vlan
Ruijie(config)#vlan 1
Ruijie(config-vlan)#vlan 2
Ruijie(config-vlan)#vlan 3
Ruijie(config-vlan)#exit
3、配置各个vlan 网关地址
Ruijie(config)#interface vlan 1
Ruijie(config-if-vlan 1)#ip address 192.168.1.1 255.255.255.0
Ruijie(config-if-vlan 1)#interface vlan 2
Ruijie(config-if-vlan 2)#ip address 192.168.2.1 255.255.255.0
Ruijie(config-if-vlan 2)#interface vlan 3
Ruijie(config-if-vlan 3)#ip address 192.168.3.1 255.255.255.0
Ruijie(config-if-vlan 3)#exit
4、DHCP功能(可选配置)
注:在AP或网关设备上选择其中一个设备配置DHCP即可。
配置参见AP配置的步骤14
5、保存配置
           Ruijie(config)#end
    Ruijie#write
五、配置验证

1、确认是否可以收到无线信号并且关联成功
4.png
2、确认无线网卡获取的IP地址是否正常,是否可以ping通网关

ping测试:“开始”菜单----“运行”---输入 cmd  后回车------输入 ping x.x.x.x    (X.X.X.X表示网关地址)

下面为多个无线信号配置脚本:
多个无线信号配置脚本.rar (710 Bytes, 下载次数: 196)
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则