设为首页   锐捷官网
用其他帐号登录:
查看: 1417|回复: 0

胖AP多个无线信号配置

[复制链接]

25

主题

25

帖子

152

积分

版主

Rank: 7Rank: 7Rank: 7

积分
152
发表于 2016-1-9 19:25:34 | 显示全部楼层 |阅读模式
本帖 * 后由 浪天涯星仔 于 2016-1-9 19:25 编辑

适用场景说明
无线网络中的AP数量较少,不需要花费太大时间和精力去管理和配置AP。此时胖AP工作模式类似一台二层交换机,担任有线和无线数据转换的角色,没有路由和NAT功能。
优点:无需改变现有有线网络结构,配置简单
缺点:无法统一管理和配置
一、组网需求
1) 在有线网络的基础上,添加一个无线AP实现网络覆盖。无线AP广播2个SSID,分别对应两个vlan。
2) AP 接在可网管的接入设备上(接口配置为trunk),交换机已经划分vlan1、vlan10、vlan20,AP 充当透明设备实现无线覆盖,用户能通过不同SSID无线接入vlan1、vlan10、vlan20获取IP 地址上网。
3)  Vlan10网段为:172.16.10.0 ; Vlan20网段为: 172.16.20.0。
二、组网拓扑
多SSID截图.png
三、配置要点
1、连接好网络拓扑, * AP 能被供电,能正常开机。
2、 * 要接AP的网线接在电脑上,电脑可以使用网络,使用ping测试。
3、完成AP基本配置后验证无线SSID 能否被无线用户端正常搜索发现到。
4、配置无线用户端的IP 地址为静态IP,并验证网络连通性。
5、AP其他可选配置(DHCP 服务、无线的认证及加密方式)
注意: * 次登陆AP配置时,需要切换AP为胖模式工作,切换命令:ruijie>ap-mode fat

以下主要是配置介绍,配置可以直接复制案例介绍 * 后的脚本文件,根据实际的网络环境修改脚本文件中的部分内容,详见案例 * 后的脚本。

四、配置步骤:
以AP型号为AP220-E为例。
步骤1 创建相关vlan
Ruijie>enable                 ------>进入特权模式
Ruijie#configure terminal     ------>进入全局配置模式
Ruijie(config)#vlan 1  ------>创建 vlan1
Ruijie(config-vlan)#vlan 10 ------>创建 无线用户vlan10
Ruijie(config-vlan)#vlan 20  ------>创建 无线用户 vlan20
Ruijie(config)#exit
步骤2 开启DHCP服务(如果网关设备有提供DHCP服务,那么请跳过此步骤)
Ruijie(config)#service dhcp
配置DHCP服务器排除地址段
Ruijie(config)#ip dhcp excluded-address 172.16.10.253 172.16.10.254 ------>DHCP不下发地址:192.168.10.253~192.168.10.254
Ruijie(config)#ip dhcp excluded-address 172.16.20.253 172.16.20.254
配置vlan10地址池test_10,test_20
Ruijie(config)#ip dhcp pool test_10 ------>地址池名字
Ruijie(dhcp-config)#network 172.16.10.0 255.255.255.0 ------>DHCP下发172.16.10.0/24网段
Ruijie(dhcp-config)#dns-server 218.85.157.99 ------>下发的DNS地址
Ruijie(dhcp-config)#default-router 172.16.10.254------>下发网关
Ruijie(dhcp-config)#exit
Ruijie(config)#ip dhcp pool test_20 ------>地址池名字
Ruijie(dhcp-config)#network 172.16.20.0 255.255.255.0 ------>DHCP下发172.16.20.0/24段
Ruijie(dhcp-config)#dns-server 218.85.157.99 ------>下发DNS地址
Ruijie(dhcp-config)#default-router 172.16.20.254 ------>下发网关
配置BVI 10和BVI 20接口地址用于DHCP分配地址
Ruijie(config)#interface bvi 10
Ruijie(config-if-BVI 10)#ip address 172.16.10.253 255.255.255.0
Ruijie(config)#interface bvi 20
Ruijie(config-if-BVI 20)#ip address 172.16.20.253 255.255.255.0
注意:如果DHCP服务器在上联设备做,请在全局配置无线广播转发功能,否则会出现DHCP获取不稳定现象
Ruijie(config)#data-plane wireless-broadcast enable
步骤3 配置wlan10接口并广播SSID为AP1,配置wlan20接口并广播SSID为AP2
Ruijie(config)#dot11 wlan 10 ------>创建wlan10接口
Ruijie(dot11-wlan-config)#vlan 10 ------>属于vlan10
Ruijie(dot11-wlan-config)#broadcast-ssid
Ruijie(dot11-wlan-config)#ssid AP1 ------>广播SSID为AP1
Ruijie(config)#dot11 wlan 20 ------>创建wlan20接口
Ruijie(dot11-wlan-config)#vlan 20 ------>属于vlan20
Ruijie(dot11-wlan-config)#broadcast-ssid
Ruijie(dot11-wlan-config)#ssid AP2 ------>广播SSID为AP2

步骤4 配置interface gig 0/1.10子接口并封装相关vlan 10,配置interface gig 0/1.20子接口并封装相关vlan 20
Ruijie(config)#interface GigabitEthernet 0/1------>主接口封装vlan的v报文没有携带vlan tag,相当于trunk的native vlan
Ruijie(config-if)#encapsulation dot1Q 1 ------>封装vlan
Ruijie(config)#interface GigabitEthernet 0/1.10  ------>配置interface gig 0/1.10子接口,数据有携带vlan tag,相当于trunk接口
Ruijie(config-if)#encapsulation dot1Q 10 ------>封装vlan
Ruijie(config)#interface GigabitEthernet 0/1.20 ------>配置interface gig 0/1.20子接口
Ruijie(config-if)#encapsulation dot1Q 20 ------>封装vlan
步骤5 配置无线信号和vlan关联
配置射频口1/0.10,1/0.20,2/0.10和2/0.20,封装vlan10,封装vlan20
Ruijie(config)#interface Dot11radio 1/0.10  ------>在子接口封装无线用户vlan
Ruijie(config-if-Dot11radio 1/0.10)#encapsulation dot1Q 10    ------>封装vlan 10
Ruijie(config-if-Dot11radio 1/0.10)#mac-mode fat
Ruijie(config)#interface Dot11radio 1/0.20  
Ruijie(config-if-Dot11radio 1/0.20)#encapsulation dot1Q 20  ------>封装vlan 20
Ruijie(config-if-Dot11radio 1/0.20)#mac-mode fat
Ruijie(config)#interface Dot11radio 2/0.10  
Ruijie(config-if-Dot11radio 2/0.10)#encapsulation dot1Q 10  ------>封装vlan 10
Ruijie(config-if-Dot11radio 2/0.10)#mac-mode fat
Ruijie(config)#iinterface Dot11radio 2/0.20  
Ruijie(config-if-Dot11radio 2/0.20)#encapsulation dot1Q 20  ------>封装vlan 20
Ruijie(config-if-Dot11radio 2/0.20)mac-mode fat
配置射频口1/0,指定802.11b,信道为1,并与wlan10和wlan20关联
Ruijie(config)#interface Dot11radio 1/0
Ruijie(config-if-Dot11radio 1/0)#mac-mode fat
注意:mac-mode 模式必须为fat,否则会出现能搜索到信号,连接不上无线网络现象
Ruijie(config-if-Dot11radio 1/0)#channel 1 ------>信道为1,802.11b中互不干扰信道为1、6、11
Ruijie(config-if-Dot11radio 1/0)#power local 100 ------>功率改为 * (默认)
Ruijie(config-if-Dot11radio 1/0)#wlan-id 10 ------>与wlan10关联
Ruijie(config-if-Dot11radio 1/0)#wlan-id 20 ------>与wlan20关联
配置射频口2/0,指定802.11a,信道为149,并与wlan10和wlan20关联
Ruijie(config)#interface Dot11radio 2/0   
Ruijie(config-if-Dot11radio 2/0)#mac-mode fat
Ruijie(config-if-Dot11radio 2/0)#channel 149 ------>信道为149,802.11a互不干扰的信道是149、153、157、161、165
Ruijie(config-if-Dot11radio 2/0)#power local 100 ------>功率改为 * (默认)
Ruijie(config-if-Dot11radio 2/0)#wlan-id 10 ------>与wlan10关联
Ruijie(config-if-Dot11radio 2/0)#wlan-id 20 ------>与wlan20关联
注意:步骤3、4、5的顺序不能更改,否者配置不成功
步骤6 配置管理地址:
Ruijie(config)#interface BVI 1
Ruijie(config-if-BVI 1)#ip address 172.16.1.253 255.255.255.0 ------>AP的管理地址,vlan 1对应bvi 1
步骤7 配置AP缺省路由:
Ruijie(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.254 ------>用于跨网段管理vlan
步骤8 保存配置
Ruijie(config)#end                ------>退出到特权模式
Ruijie#write                   ------>确认配置正确,保存配置
注释:
vlan 10,“10”代表vlan-id 10;dot11 wlan 10,“10”代表wlan-id 10。
vlan 20,“20”代表vlan-id 20;dot11 wlan 20,“20”代表wlan-id 20。
五、配置验证
无线用户可以搜索到SSID AP1和AP2,用户能通过无线获取到IP,并能正常上网

注意:早期AP版本与部分网卡存在兼容性问题,升级到 * 稳定版本。

下面为无线胖AP的脚本:
胖AP多个无线信号配置脚本.rar (701 Bytes, 下载次数: 150)
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则