设为首页   锐捷官网
用其他帐号登录:
查看: 2246|回复: 9

[教材专区] 交换机高级配置技术

[复制链接]

6

主题

33

帖子

106

积分

初级会员

Rank: 2

积分
106
发表于 2017-10-5 22:57:33 | 显示全部楼层 |阅读模式
2.11  IPV6静态路由配置
提问:IPV6静态路由怎么配置?
回答:
S3760(config) # ipv6route 2001:20::/642001::2
---格式:ipv6 route  子网/掩码  下一跳



———————————————————————————————————————
2.12  IPV6隧道配置
提问:IPV6手工隧道如何配置?
回答:
S3760(config)#interface Tunnel 1
S3760(config-if-Tunnel1)#ipv6 enable                         ---使能IPV6协议栈
S3760(config-if-Tunnel1)#tunnel source 10.1.1.1            ---指定隧道源IPV4地址
S3760(config-if-Tunnel1)#tunnel destination 10.1.1.2     ---指定隧道目的IPV4地址
S3760(config-if-Tunnel 1)#tunnel mode ipv6ip                    ---使能手工隧道

提问:6to4隧道如何配置?
回答:
S3760 (config)#interface Tunnel 1
S3760(config-if-Tunnel 1)#ipv6 enable
S3760(config-if-Tunnel 1)# ipv6 address 2002:1414:1401::1/64    ---配置6to4地址
S3760 (config-if-Tunnel1)# tunnel source 20.20.20.1       ---指定隧道源IPV4地址
S3760(config-if-Tunnel 1)# tunnel mode ipv6ip 6to4              ---使能6to4隧道

注意:6to4地址内嵌的IPV4地址不能为私有的IPV地址(如10.0.0.0/8、172.16.0.0/12、192.168.0.0/16网段地址)必须是全局的IPV4地址

提问:ISATAP隧道如何配置?
回答:
S3760 (config)#interface Tunnel 1
S3760(config-if-Tunnel 1)#ip address 192.168.30.254 255.255.255.0
S3760(config-if-Tunnel 1)# ipv6 address 2001:30::1/64
S3760(config-if-Tunnel 1)#ipv6 enable                      ---使能IPV6协议栈
S3760(config-if-Tunnel 1)# no ipv6 nd suppress-ra           ---允许发送RA报文
S3760(config-if-Tunnel 1)# tunnel source 192.168.30.254   ---指定隧道源IPV4地址
S3760(config-if-Tunnel 1)# tunnel mode ipv6ip isatap           ---使能isatap隧道

注意:设备上允许同时配置多个ISATAP隧道,但是每个ISATAP隧道的suorceipv4地址必须不同



———————————————————————————————————————
2.13交换机上启用RLDP防环检测配置
提问:如何开启交换机的RLDP功能?
回答:
1、开启功能
S3760 #conf  t
S3760(config) # rldpenable                                 --开启全局RLDP功能
S3760(config)#interface f 0/1
2、配置处理方式。四种处理方式只能选其一
S3760(config-if)#rldp port loop-detect shutdown-port      --检测到后将端口关闭
S3760(config-if)#rldp port loop-detect warning          --检测到后,输出警告信息
S3760(config-if)#rldp port loop-detect block    --检测到后将关闭端口学习转发功能
S3760(config-if)#rldp port loop-detect shutdown-svi
--检测到后关闭端口所在的VLAN
3、保存配置
S3760(config-if)# end
S3760# wr                                                            ---保存

注意:
1)  可网管型交换机防环一般使用STP即可,若交换机下连的是傻瓜交换机,或者PC,可以在所连接的接口上启用RLDP功能。
2)  检测到环路后接口会进行处理,重新打开接口的命令:
S3760(config)#errdisable recovery  
3)  路由口不支持shutdown-svi的错误处理方法,因此该方法在路由口发生检测错误时将不被执行。
4)  配置环路检测时要求端口下连的邻居设备不能开启RLDP检测,否则该端口将无法做出正确的检测。  
5)  如果在aggregateport 上配置了block方法并且端口发生了链路检测错误,则在端口重新恢复检测前不需要变更该aggregate port的成员口关系,否则成员口的转发状态将会和实际的设备效果不一致。
6)  如果RLDP检测出链路错误,则会发出警告信息。用户可以通过配置log功能将这些警告信息发到log服务器,记录log的级别至少要保证可以记录 3级日志。



———————————————————————————————————————
2.14交换机上配置VRRP
提问:怎么配置VRRP
回答:
步骤一:
Master:
ruijie(config)#track1 interface f0/0                                ---端口追踪
ruijie(config)#interfaceVlan 10
ruijie(config-if)#ipaddr 10.10.10.1 255.255.255.0
ruijie(config-if)#vrrp1 priority 120      ---设置优先级,默认100,优先级高的成为主
ruijie(config-if)#vrrp1 ip 10.10.10.10                             ---配置虚拟网关
ruijie(config-if)#vrrp1 timer advertise 3                       ---调定时器,可选
ruijie(config-if)#vrrp1 preempt                                        ---配抢占
ruijie(config-if)#vrrp1 track 1  100                      ---追踪端口优先级降低值
步骤二:
Backup:
ruijie(config)#interfaceVlan 10
ruijie(config-if)#ipaddr 10.10.10.2 255.255.255.0
ruijie(config-if)#vrrp1 priority 100                        ---设置优先级,默认100
ruijie(config-if)#vrrp1 ip 10.10.10.10
ruijie(config-if)#vrrp1 timer advertise 3                       ---调定时器,可选
ruijie(config-if)#vrrp1 preempt                                       ---配抢占

验证:验证结果
      show vrrp [brief]
      show vrrp interface 接口
      show track

小结:
简单来说 VRRP是一种容错协议它为具有组播或广播能力的局域网 如以太网 设计它保证当局域网内主机的下一跳路由器出现故障时 可以及时的由另一台路由器来代替从而保持通讯的连续性和可靠性 为了使VRRP工作要在路由器上配置虚拟路由器号和虚拟IP地址同时产生一个虚拟MAC地址这样在这个网络中就加入了一个虚拟路由器 而网络上的主机与虚拟路由器通信无需了解这个网络上物理路由器的任何信息 一个虚拟路由器由一个主路由器和若干个备份路由器组成主路由器实现真正的转发功能 当主路由器出现故障时 一个备份路由器将成为新的主路由器接替它的工作。



———————————————————————————————————————
2.15交换机上保护端口的配置
提问:如何配置交换机的保护端口功能?
回答:
S2126G>en
S2126G#con
S2126G(config)#intf0/1                                              ----进入接口FastEthernet 0/0口
S2126G(config-if)#switchportprotected                       ----开启保护端口功能                                                         
S2126G(config-if)#end
S2126G#wr
注意:保护端口之间互相隔离,不能通信,保护端口和非保护端口之间可以通信。目前支持保护端口的接入/汇聚交换机系列有S20、S21、S23、S26、S32、S3750、S5750。



———————————————————————————————————————
2.16 交换机Super VLAN配置
步骤一:创建VLAN
S5750A>en
Password:
S5750A#configure
S5750A(config)#vlan 2
S5750A(config-vlan)#exit
S5750A(config)#vlan 3
S5750A(config-vlan)#exit
S5750A(config)#vlan 4
S5750A(config-vlan)#exit
S5750A(config)#   
         ----创建三个VLAN
步骤二:配置supervlan
S5750A(config)#vlan 3
S5750A(config-vlan)#supervlan                       ----配置VLAN3为supervlan
S5750A(config-vlan)#subvlan2,4                  ----配置VLA2,VLAN4为subvlan

步骤三:把相应接口指定到相应的subVLAN中
S5750A(config)#interfacegigabitEthernet 0/4
S5750A(config-if-GigabitEthernet0/4)#switchport access vlan 2
----把交换机的第4端口划到subVLAN 2中
S5750A(config-if-GigabitEthernet0/4)#exit
S5750A(config)#interfacegigabitEthernet 0/5
S5750A(config-if-GigabitEthernet0/5)#switchport access vlan 4
----把交换机的第5端口划到subVLAN 4中
S5750A(config-if-GigabitEthernet0/5)#
S5750A(config-if-GigabitEthernet0/5)#exit
步骤四:设置SubVLAN 2的IP 地址空间
S5750A(config)#vlan2
S5750A(config-vlan)#subvlan-address-range192.168.1.1 192.168.1.100
                                            ----设置SubVLAN 2 下的IP 地址空间
S5750A(config-vlan)#exit
S5750A(config)#vlan4
S5750A(config-vlan)#subvlan-address-rang192.168.1.101 192.168.1.253                                                  
                                           ----设置SubVLAN 4 下的IP 地址空间
S5750A(config-vlan)#exit
步骤五:创建SuperVLAN 对应虚拟三层接口
S5750A(config)#interfacevlan 3
S5750A(config-if-VLAN3)#ip address 192.168.1.254 255.255.255.0
                                                ----为SUBVLAN的用户配置网关
步骤六:保存配置
S5750A(config)#end
S5750A#wr



———————————————————————————————————————
2.17交换机上启用WEB管理功能
提问:如何使用WEB管理?
回答:
s27>en
s27#con
s27(config)#enableservice web-server                       --全局开启web功能
s27(config)# int vlan1
s27(config-if)# ipadd 192.168.1.254 255.255.255.0  
--配置管理地址,假设管理vlan为1,管理地址为192.168.1.254
s27(config-if)#noshut
s27(config-if)#exit
s27(config)#enablesecret level 15 0 ruijie          --配置特权密码,假设密码为ruijie
s27(config)#end
s27#wr
设备登录:
1)    浏览器中输入管理地址,提示如下界面:
file:///C:/Users/ADMINI~1/AppData/Local/Temp/msohtmlclip1/01/clip_image002.jpg
2)    输入特权密码,用户名任意。
file:///C:/Users/ADMINI~1/AppData/Local/Temp/msohtmlclip1/01/clip_image004.jpg
3)    Web界面显示
file:///C:/Users/ADMINI~1/AppData/Local/Temp/msohtmlclip1/01/clip_image006.jpg

注意:
目前支持web管理的交换机包括S23系列,S26系列,S27系列,S29系列;
支持版本为10.2(4)及以上版本。

———————————————————————————————————————
2.18 锐捷交换机日志服务器配置
提问:如何配置设备的syslog功能
回答:
第一步:开启log服务器功能,并制定log服务器的地址
ruijie(config)#loggingon                                         ---开启log功能
ruijie(config)#logging192.168.1.1             ---指定log服务器的地址,可以填写多个
第二步:指定snmp-server地址,并制定发送trap消息的源地址(可选)
ruijie(config)#servicetimestamps log datetime  ---发送记录事件的时候包含时间标记
ruijie(config)#servicetimestamps debug datetime         --- syslog信息包含时间戳
第三步:设置设备的时间(或者设置SNTP服务器)
ruijie#clock set8:45:00 10 13 2009              ---设置设备当前时间为2009-10-13
ruijie#showclock                                     ---查看当前设备的系统时间
08:45:06 CHN-BJ Tue2009-10-13
第四步:指定发送的时间戳:
ruijie(config)#loggingfacility local7
---定义facility级别,缺省为local7,可以设置从local0到local7
ruijie(config)#loggingtrap warnings           ---定义severity级别缺省为infor级别
第五步:保存设备配置
ruijie#write



———————————————————————————————————————
2.19交换机上配置Hybrid接口
提问:怎么配置Hybrid接口
回答:
Hybrid接口能够控制哪些些VLAN ID能够被上传,哪些VLAN ID禁止上传.下面举一个例子,主VLAN50,从VLAN是51-54,要实现51-54不能上传VLAN ID,只允许上传VLAN ID 50。具体配置如下:
vlan 50                                                          ---配置主VLAN
private-vlan primary
private-vlan association add 51-54                            ---配置关联从VLAN
!         
vlan 51
private-vlan isolated                                          ---配置隔离VLAN
!
vlan 52
private-vlan community                                       ---配置团体VLAN
!
vlan 53
private-vlan community
!
vlan 54
private-vlan community
!
interfaceFastEthernet 0/1
switchport mode private-vlan host                                ---宣告主机端口
switchport private-vlan host-association 5051             ---设置端口属于的VLAN
!
interfaceFastEthernet 0/2
switchport mode private-vlan host
switchport private-vlan host-association 50 52
!
interface FastEthernet0/3
switchport mode private-vlan host
switchport private-vlan host-association 50 53
!
interfaceGigabitEthernet 0/26
switchport mode hybrid                              ---配置端口属于Hybrid模式
switchport hybrid native vlan 50                             ---native VLAN为50
switchport hybrid allowed vlan add untagged51-54 ---禁止VLAN ID 51-54上传VID
!
interface VLAN 1                                                 ---管理VLAN
ip address 10.10.100.100 255.255.255.0
no shutdown

注释:
S21不支持Hybrid端口,S2010.2(5)版本支持,其他S20以上版本均支持。

回复

使用道具 举报

0

主题

15

帖子

43

积分

新手上路

Rank: 1

积分
43
发表于 2017-12-21 10:47:02 | 显示全部楼层
不错。值得学习啊,顶一个












v:qianbao5219  
①银闪付,瀚银旗下无卡支付,一清有牌照,直接银联支付,非扫码!无风控,可大额!现在加入,联系我 直接升级为运营商!开独立代理后台,享受0.29+2的超低费率,分享即可拿分润!

②钱宝自选商户机器免费送 带闪付功能, 银联通道结算 资金更安全!定位本地,可根据消费时间段自选本地商户,想刷什么就刷什么   绝不跳码!!!老司机都懂稳定不跳的重要性。养卡提额神器!   支持京东白条闪付,支持云闪付0.3  优惠类商户0.48.支持微信 支付宝 银联钱包扫码,支持闪付挥卡支付。

乐刷刷宝自选商户 想刷什么商户就刷什么商户,加入VIP,费率低于大多数品牌一

级代理商成本价!

③钱宝全国招商!做代理,拿分润(总部直发)!用最优惠费率!自己的费率自己做主!
乐刷刷宝自选pos全国招商!寻合作伙伴!分润日结!分润日结!分润日结!
回复 支持 反对

使用道具 举报

0

主题

2

帖子

3

积分

新手上路

Rank: 1

积分
3
发表于 2018-4-6 17:26:38 | 显示全部楼层
回顾一下交换技术,有感觉!充实起来。
回复 支持 反对

使用道具 举报

0

主题

1365

帖子

1585

积分

金牌会员

Rank: 6Rank: 6

积分
1585
发表于 2018-5-17 20:21:32 | 显示全部楼层
回复 支持 反对

使用道具 举报

0

主题

1365

帖子

1585

积分

金牌会员

Rank: 6Rank: 6

积分
1585
发表于 2018-5-23 21:54:11 | 显示全部楼层
回复 支持 反对

使用道具 举报

0

主题

1365

帖子

1585

积分

金牌会员

Rank: 6Rank: 6

积分
1585
发表于 2018-5-25 22:27:05 | 显示全部楼层
回复 支持 反对

使用道具 举报

0

主题

1365

帖子

1585

积分

金牌会员

Rank: 6Rank: 6

积分
1585
发表于 2018-5-27 21:11:12 | 显示全部楼层
回复 支持 反对

使用道具 举报

0

主题

1365

帖子

1585

积分

金牌会员

Rank: 6Rank: 6

积分
1585
发表于 2018-5-29 12:29:42 | 显示全部楼层
回复 支持 反对

使用道具 举报

0

主题

1365

帖子

1585

积分

金牌会员

Rank: 6Rank: 6

积分
1585
发表于 2018-6-3 14:57:47 | 显示全部楼层
回复 支持 反对

使用道具 举报

0

主题

1365

帖子

1585

积分

金牌会员

Rank: 6Rank: 6

积分
1585
发表于 2018-7-3 23:02:48 | 显示全部楼层
看看吧,大家都会支持你












柳州商标注册公司 广西商标注册 柳州商标注册 柳州商标公司 广西商标注册公司
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则